Improvement On Page Loading Time

Tips submitted by PHPMaker users
Post Reply
redneck
User
Posts: 10

Improvement On Page Loading Time

Post by redneck »

Since I'm using PHPMaker 2021, I'm focusing on page load time, which is increasing.

I have around 300 tables in my database. When I'm using PHPMaker 12, the loading time is considerable. Not slow and not fast also. Unfortunately since I'm migrating my project to PHPMaker 2021, the loading time for each page is slow.

I have checking on my configuration, rewriting the project file and simplify the lookup tables and the queries. However, none of them works.

Then I decided to decouple the modules and break them into separated project files. To bridge every modules, I'm using identical project name & project ID which you can find the settings in Advanced Settings. This way, we can jump into every modules from the menu without having to login again since every modules sharing the same session.

This improvement lowering the page loading time from around 12 seconds to only 2.4 seconds.

Hope this helps you guy who is struggling on decreasing the loading time. πŸ™‚


mobhar
User
Posts: 11841

Post by mobhar »

Thanks for sharing.

You may try v2023. There is a big improvement of page loading time.

FYI, I compared v2022 vs v2023, the page loading time becomes faster significantly.


arbei
User
Posts: 9603

Post by arbei »

  1. You better use PHP 8, see PHP 8.0.0 Release Announcement -> Just-In-Time compilation:
    PHP 8 introduces two JIT compilation engines. Tracing JIT, the most promising of the two, shows about 3 times better performance on synthetic benchmarks and 1.5–2 times improvement on some specific long-running applications. Typical application performance is on par with PHP 7.4.

  2. When you deploy, you may change to production settings to improve performance, read Environment.


amiens80
User
Posts: 450

Post by amiens80 »

300 tables (or relation) is huge !

also, if your server have more memory, you could extend the cache size for lookup table, did you check the LOOKUP_CACHE_COUNT parameter ?


Post Reply