Code panel not showing code

This public forum is for user-to-user discussions of PHPMaker. Note that this is not support forum.
Post Reply
iggabz
User
Posts: 101

Code panel not showing code

Post by iggabz »

Good day,

My code panel does not show anything. i have already restarted the laptop and have already updated the template.

any work around for this? i have already tried searching for relevant issue but nothing is of the same concern.


arbei
User
Posts: 9532

Post by arbei »

  1. Make sure you have installed the WebView2 runtime, see system requirements. If you are using v2024.10, you should install 123.0.2420.97 because the latest 1.0.2478.35 was released after v2024.10.
  2. Restart PHPMaker,
  3. It should work, it not, you can use the old editor, see Code Editor.

iggabz
User
Posts: 101

Post by iggabz »

thank you


hemin
User
Posts: 167

Post by hemin »

i have the same issue , i have the latest version installed in the code editor it shows this error : Failed to load resource: net::ERR_FILE_NOT_FOUND
loader.js:1


    Failed to load resource: net::ERR_FILE_NOT_FOUND

editor.main.nls.js:1


    Failed to load resource: net::ERR_FILE_NOT_FOUND

editor.main.js:1


    
    Failed to load resource: net::ERR_FILE_NOT_FOUND

VM8:1 BuyNow driver Initialized!!!!!!
VM8:1 MsnDriver starts
codeeditor.min.js:5 Uncaught ReferenceError: monaco is not defined
at new CodeEditor (codeeditor.min.js:5:293)
at index.html?rnd=1965138357:14:30

i have WebView2 125.0.2535.51 , tried to remove but control panel won't let me only gives the option to repair.


arbei
User
Posts: 9532

Post by arbei »

  1. If you use v2024.11, you better install WebView2 124.0.2478 (because the latest NuGet package for WebView2 is still 1.0.2478.35).
  2. If you see "Failed to load resource", the WebView2 should be already running. The error may not be due to WebView2, make sure your PC is connected to internet and you have completed the npm update when you first open PHPMaker. You may delete C:\Users\<user>\AppData\Roaming\phpmaker2024 and open PHPMaker again. Make sure you have not disabled Update template on start.

hemin
User
Posts: 167

Post by hemin »

Thanks, i followed step 2 but still the same.

the problem with step one is i don't know how to go back to old version as from the microsoft website i get .cab file and on my laptop the latest version is installed and can't even remove because its part of edge.

I wonder how did @iggabz fix it?


arbei
User
Posts: 9532

Post by arbei »

Go to C:\Users\<user>\AppData\Roaming\phpmaker2024, make sure you have "node_modules\monaco-editor" folder, if not, open a command prompt and run "npm update", make sure it completes without error.


Post Reply