Input Values and Requires Search

This public forum is for user-to-user discussions of PHPMaker. Note that this is not support forum.
Post Reply
skyking
User
Posts: 37

Input Values and Requires Search

Post by skyking »

I have two tables recip-name and dao-activity

recipname is set to default so when I load the site it defaults to recipnamesearch as it should (recip-name set to requires search)

dao-activity is also set to requires search but clicking on the link in the sidebar brings up daoactivitylist instead of search and there is a selected record in the list and the SQL query shows the query with search information that wasn't entered in the current session. I cleared cache and cookies and it always comes up with a previous search.

Debug:
sql: SELECT COUNT(*) FROM guilds, executionMS: 0.065430879592896

sql: SELECT guildid AS lf, guild AS df, '' AS df2, '' AS df3, '' AS df4 FROM guilds, executionMS: 0.064788818359375

sql: SELECT COUNT(*) FROM dao-activity WHERE recipid = 'myepic', executionMS: 0.065451860427856

sql: SELECT * FROM dao-activity WHERE recipid = 'myepic' LIMIT 4, executionMS: 0.056880950927734

Why is it bypassing initial Search for dao-activity and where is it getting previous search data when cache and cookies were reset?


arbei
User
Posts: 7915

Post by arbei »

As explained in the docs, "Requires Search" means:

If enabled, the List page always requires search criteria. When the page is initially loaded, no records will be displayed until searching is done. (Remember to enable Quick Search, including Extended Quick Search, or Advanced Search or both.

You may not have enabled Quick Search or Extended Quick Search (in List page) for the recip-name table, so it can only go to the Advanced Search page (recipnamesearch) first since it "Requires Search".

For the dao-activity table, you may have enabled Quick Search or Extended Quick Search, so it goes to the List page.

All search criteria are persisted by session variables so you can switch between tables. If you want to clear search criteria, you should click the clear search button ("Show All") in the List page.


Post Reply