Cannot Get ASP.NET Maker to Save Framework as .NET Core 2.0?

This public forum is for user-to-user discussions of ASP.NET Maker. Note that this is not support forum.

Cannot Get ASP.NET Maker to Save Framework as .NET Core 2.0?

Postby davemackey » Wed Sep 27, 2017 8:42 am

Hi All,

Just trying out the trial download. I have .NET Core 2.0 installed on my machine. When I tried generating a site I got an error message that I needed to install .NET Core 1.1 or change the advanced settings to reflect that I was using .NET Core 2.0. I did this and clicked ok, but when I went to generate it again said I needed .NET Core 1.1 or to change the Advanced Settings. I went back into advanced settings and it had not saved the update I had made to specify .NET Core 2.0.

I did this several times over to no avail. Any ideas?

Thanks!
Dave
davemackey
 
Posts: 1
Joined: Wed Sep 27, 2017 8:38 am

Re: Cannot Get ASP.NET Maker to Save Framework as .NET Core

Postby Webmaster » Wed Sep 27, 2017 9:17 am

1. Most importantly, make sure you are using v2017.0.5. (Older versions were released before .NET Core 2.0 and did not support .NET Core 2.0.)

2. Make sure your PC is using .NET SDK 2.0, verify by opening a command prompt and type:

dotnet --info

You should see something like: (the following example is for x86 version)

.NET Command Line Tools (2.0.0)

Product Information:
Version: 2.0.0
Commit SHA-1 hash: cdcd1928c9

Runtime Environment:
OS Name: Windows
OS Version: 10.0.15063
OS Platform: Windows
RID: win10-x86
Base Path: C:\Program Files (x86)\dotnet\sdk\2.0.0\

3. Click Tools -> Advanced Settings, set:

Target Framework: net461 (or newer)
ASP.NET Core version: 2.0.0

Then generate again.
Webmaster
 
Posts: 10733
Joined: Fri Aug 06, 2004 5:59 pm


Return to General Discussion (ASP.NET Maker)



cron