Resolve MSSQL Advanced Security Login Issues

Tips submitted by ASP.NET Maker users

Resolve MSSQL Advanced Security Login Issues

Postby xgis » Sun Feb 26, 2017 9:33 pm

This fix applies to ANM12/2016/2017 Security Settings where users are redirected to an error page stating "Invalid object name 'YourLoginTableName'.
The error page in this case highlights the User Profile as having an issue writing to the database users table.
The UserProfile field itself can be of type; text, ntext, or nvarchar(max) in MSSQL if memo is not available.
After the user sees the error page the user is actually authenticated but needs to click the back button to see the tables.

To resolve the issue go to; Security | Advanced | User Login Options | Track Failed Attempts (checkbox)
Deselect it if selected
This then resolves the error page and login should work fine.

In the event your AGX does not display the "Profile Field (memo)" you can write in the exact field name in the drop-down box
or manually edit the AGX and add your profile field name to the following field; SecUserProfileFld="YourUserProfileFieldName"
It is best to close and save the ANM project before you edit, otherwise you may save over your edits.
Then restart the project and check the Security Advanced settings to ensure the fields display.
xgis
 
Posts: 87
Joined: Thu Jan 17, 2013 10:40 pm

Return to User Submited Tips (ASP.NET Maker)