Resolve "Class Not Registered" Errors in IIS 7.5-8.5

Tips submitted by ASP.NET Maker users

Resolve "Class Not Registered" Errors in IIS 7.5-8.5

Postby xgis » Fri Dec 27, 2013 12:04 am

When sending a site live on an IIS Webserver significant downtime can be experienced if settings are not correct.
This error may also present itself when you have RDP'd to the site and are testing through the live server IIS.
It is important to try and concurrently run the live website from your local machine or on a PDA or mobile to check when it renders and goes live.
These changes are relevant to a Windows 2012 x64 Server running IIS8.5 against MSSQL 2012 Express.
If you are not sure of how to implement these changes it is important to seek advice.

Important considerations;
1. App_Pool issues related to server architecture (x32 vs x64)
2. App_Pool Managed Pipeline
3. App_Pool Identity

These settings may or may not be issues when testing on a localhost port but may prevent a live site from rendering.

1. Select the App_Pool related to your site and right click to select Advanced Settings. Change "Enable 32 Applications" from False to True, especially if you are on an x64 Server.
2. Ensure the Managed Pipeline is set to "Integrated"
3. The App_Pool identity on localhost generally uses your active windows login. On the live server it may use "AppPoolIdentity" by default, depending on how recent your windows server version is.
If it will not enable you to render the site because it does not have sufficient permission to access the MSSQL database then set it to the logged in user of the server.. eg Administrator (you will need the password to do this)
xgis
 
Posts: 87
Joined: Thu Jan 17, 2013 10:40 pm

Return to User Submited Tips (ASP.NET Maker)