Vista IIS 7.0, - Microsoft JET Database Engine error '800040

Tips submitted by ASPMaker users

Vista IIS 7.0, - Microsoft JET Database Engine error '800040

Postby JCrowe » Sun Jan 11, 2009 11:18 am

Microsoft JET Database Engine error '80004005'
Unspecified error

Now that Vista is getting splattered on most new machines without the ability to get rid of it - at least my new laptop would not let me format over it, the machine refused to boot from an XP disc !

So, I spent 3 days trying to figure out this new gadget called IIS 7 only to be disappointed that my ASPMaker application failed. I could stick a simple default.asp "hello world" page in the root and it would work fine but a big NO GO for ASPMaker application connected to an Access database.

Assuming you are using your Vista Home Premium box for development there are a couple of things you must do to get IIS 7 up and going.

1. INSTALL IIS via the Control Panel - it is not insalled by default.
2. Ensure you enable Classic ASP during to the install - it is located in one of those neatly hidden blue check boxes.

3. Once it installs - open the the Advanced settings section and select "Enable Parent Paths" otherwise if you develop folders below the root folder your application will not find your includes...etc.

4. While in the Advanced settings find the box that says to send error messages to the browser.

5. Set the Read/Write permissions on your database folder via Windows explorer - Folder, right click your *.mdb , add ISUR_machinename with Read/Write/Modify

At this point I copied my ASPMaker application into the inetpub/www/root typed in then http://localhost - only to be laughed at by IIS7 !

6. When you get the error Microsoft JET Database Engine error '80004005' Unspecified error - Drink a six pack and eat a xanax

7. After days of searhcing I found this sweet command to be run from the START > RUN > command box :
icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant Users:(CI)(S,WD,AD,X)

The Microsoft technobable is this - "With IIS7, we've chosen a more secure default and now load user profile by default for all application pools. Unfortunately, the temporary directory underneath the user directory (for example - %windir%\serviceprofiles\networkservice\AppData\Local\Temp for the default NetworkService identity we use for DefaultAppPool) is not writable by anyone other than NetworkService by default."

8. At this point I didnt care WHY it worked, just that it did work - You can read the full article at ... 32879.aspx

For more info about IIS 7 start here -

Re: Vista IIS 7.0, - Microsoft JET Database Engine error '800040

Postby JCrowe » Wed Jan 21, 2009 11:12 am

Updated 1/20/2008

I had to re-format my Vista - sux machine (again) due to corrupt files from Expression Web.

So I am thinking "no sweat, I have the trick to get IIS 7 up and running on the local machine quickly."

Looks like you have to run two changes and you may still have an issue:

Make sure you are running as the admin by turning of the ACL in Control Panel -> User Accounts - Uncheck ACL

------------------------Run these two commandes from Start - > Run-----------------------------------------------------

icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant Users:(CI)(S,WD,AD,X)
icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER":(OI)(CI)(IO)(F)


Test your connection.

Once you have done this you may still find you have a problem. I found that when I ran the commands the Temp directory was not getting updated properly. I dont think it is the commands becuase it work before plus you can refernce those commands across the internet.

Next Step:
Insure you turn on "Show Hidden FIles and Folders" (open explorer, click the ALT button, select tools, folder options).
Trace the folded path down to c:\windows\serviceprofiles\networkservice\AppData\Local\Temp

Add IUSR account with full permissions - Test your site

Hopefully this will help someone else.


Re: Vista IIS 7.0, - Microsoft JET Database Engine error '80

Postby Krammig » Fri Jul 01, 2011 3:58 pm

Thanks for the detailed info,

I wish I could say this worked. I have tried all the above, and other things, but no go. Running Windows 7 with IIS 7.5 SQL works fine but Access mdb I just cannot get to work.

Re: Vista IIS 7.0, - Microsoft JET Database Engine error '80

Postby ethomas » Wed Oct 02, 2013 8:55 pm

I have found that changing your app pool to 32bit solves my "Unspecified Errors"!
Apparently the ODBC drivers are only 32bit and they don't work as well in some kind of 64bit wrapper mode in the old ASP environment.
Posts: 5
Joined: Fri Sep 27, 2013 9:17 pm

Return to User Submitted Tips (ASPMaker)