Object required: '' error in userpriv.asp line 744

This public forum is for user-to-user discussions of ASPMaker. Note that this is not support forum.

Object required: '' error in userpriv.asp line 744

Postby DooWrong » Fri Oct 06, 2017 7:25 pm

Just upgraded a project from ASPMaker2017 to ASPMaker2018 and now get the error below when accessing any user permission page.

Microsoft VBScript runtime error '800a01a8'
Object required: ''
/userpriv.asp, line 744

code:
Dim ar, i, tempPriv, item
ReDim ar(TableNameCount - 1)
For i = 0 to TableNameCount - 1
744: tempPriv = Security.GetUserLevelPrivEx(TableList(4,i) & TableList(0,i), UserLevels.UserLevelID.CurrentValue)
DooWrong
 
Posts: 2
Joined: Thu Apr 17, 2014 6:01 am

Re: Object required: '' error in userpriv.asp line 744

Postby Webmaster » Sat Oct 07, 2017 7:51 am

To show which variable is causing the error, try writing out the variables:

Response.Write "Table(4," & i & "):" & TableList(4,i) & "<br>" '***
Response.Write "Table(0," & i & "):" & TableList(0,i) & "<br>" '***
Response.Write "UserLevelID:" & UserLevels.UserLevelID.CurrentValue & "<br>" '***
tempPriv = Security.GetUserLevelPrivEx(TableList(4,i) & TableList(0,i), UserLevels.UserLevelID.CurrentValue)
Webmaster
 
Posts: 10731
Joined: Fri Aug 06, 2004 5:59 pm


Return to General Discussion (ASPMaker)